Earthquake Monitor v2.0.1 released

Dear readers,

2 weeks ago I have released v2.0.0 of the earthquake monitor. A lot has changed in this release.

Today v2.0.1 is released with some little bug fixes!

  • Added a new variable {tsunami}. When enabled in menu and added to the template it shows a tsunami icon when a major event in an oceanic region has occured.
  • Added a new variable {type} that will display the type of event (earthquake ,quarry, chemical explosion e.t.c.)
  • Added shortcode [eqmonitor] to add (multiple) earthquake lists in pages or posts (more details in the Shortcode examples and parameters section of this readme)
  • Switched to Semantic Versioning MAJOR.MINOR.PATCH
  • All links that take care of JSON data-exchange are now HTTPS (SSL)
  • All links to PHP documentation are now HTTPS
  • Adjusted the yellow pager color to be a bit more darker (and readable on white backgrounds) (This can be altered in the CSS)
  • You can now use this widget multiple times on the same site. Each widget has an unique identifier and uses itโ€™s own unique cache.

You can try it out here : https://nl.wordpress.org/plugins/earthquakemonitor

Oh, and here is a live example of the shortcode that has been added.

  1. M 7.5 - 45km NE of Kokopo, Papua New Guinea 4 days ago Tsunami Icon
  2. M 7.1 - 33km NW of Bulolo, Papua New Guinea 2 weeks ago Tsunami Icon
  3. M 7.0 - 23km NNE of Azangaro, Peru 3 months ago Tsunami Icon
  4. M 7.5 - 111km ESE of Palora, Ecuador 3 months ago Tsunami Icon
  5. M 7.0 - 96km ESE of Pondaguitan, Philippines 5 months ago Tsunami Icon
  6. M 7.3 - 83km W of Nikol'skoye, Russia 5 months ago Tsunami Icon
  7. M 7.1 - 54km N of Bristol Island, South Sandwich Islands 5 months ago Tsunami Icon
  8. M 7.5 - 165km ESE of Tadine, New Caledonia 5 months ago Tsunami Icon
  9. M 7.1 - 14km NNW of Anchorage, Alaska 6 months ago Tsunami Icon
  10. M 7.0 - 118km E of Kimbe, Papua New Guinea 7 months ago Tsunami Icon

3 thoughts on “Earthquake Monitor v2.0.1 released”

  1. Hi I like the Earthquake Monitor plugin wery mush !
    But now I have a problem with it if I swish my PHP from V 5,6 the new PHP 7 it stops showing Is there a way to fix this ? I’m still running PHP 5,6 as my users like this Earthquake Monitor !
    Thanks
    Einar B

    1. Hi Einar,

      I am running on PHP 7.2.15 and it works correctly. So in order to find out what is going wrong I need the output of the apache error.log. Do you have access to that?

  2. Cris,
    Is there a way to contact you directly, the plugin is sending errors in the errorlog and I like to share them with you, just in case you can make sense of them ๐Ÿ™‚

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.